Back to overview
Downtime

Admin Portan is down

Jun 15, 2023 at 1:15pm UTC
Affected services
Heartland POS

Resolved
Jun 15, 2023 at 1:19pm UTC

We have identified the root cause and have a fix

Created
Jun 15, 2023 at 1:15pm UTC

Users at this time may not be able to use the admin portal. Our team is currently working on this and we will update when there is a resolution